Usuario del software
2010-09-08 08:50:16 +0000 2010-09-08 08:50:16 +0000

Respuestas [12]

35
2010-09-08 16:40:40 +0000

Esto suele ocurrir si hay un desajuste entre las versiones instaladas de JDK y Eclipse de 32 y 64 bits.

Su versión de Eclipse está tratando de acceder a un JDK de 32 bits (como se indica en C:\NArchivos de Programa (x86)), pero falla porque Eclipse está esperando un JDK de 64 bits o porque el JDK de 32 bits está ausente - en consecuencia, tendrá que asegurarse de hacer coincidir las versiones de Eclipse y JDK en cuanto a bits.

35
3
2011-08-26 13:56:20 +0000

Había instalado tanto el JDK como las versiones de 64 bits de Eclipse, pero tenía el mismo problema...

Finalmente descubrí que mi variable de sistema %PATH% no incluía la carpeta. No olvides cambiarla a la carpeta correcta donde está instalado tu JDK\bin. A mí me funcionó.

3
2
2012-03-13 13:29:26 +0000
-startup
plugins/org.eclipse.equinox.launcher_1.1.1.R36x_v20101122_1400.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.2.R36x_v20101222
-product
org.eclipse.epp.package.java.product
--launcher.defaultAction
openFile
--launcher.XXMaxPermSize
256M
-showsplash
org.eclipse.platform
-vm
C:/Program Files/Java/jdk1.6.0_32/jre/bin
--launcher.XXMaxPermSize
256m
--launcher.defaultAction
openFile
-vmargs
-Dosgi.requiredJavaVersion=1.5
-Xms40m
-Xmx512m

usar eclipse y os ambos de 64 bits o ambos de 32 bits

2
1
2011-06-13 04:40:45 +0000

Tenía un Eclipse de 64 bits y Java de 32 bits y tenía el mismo problema. Después de instalar Java de 64 bits y actualizar la ruta del sistema_ , no hay problemas.

1
1
2011-06-08 09:04:41 +0000

Si has descargado Eclipse de 64 bits y un JDK/JRE de 64 bits, comprueba la disponibilidad de javaw.exe para 64 bits.

En mi caso estaba en C:\Program Files\Java\jre6\bin

He extraído Eclipse a la carpeta c:\eclipse; dentro de ella está disponible el archivo eclipse.ini. Sustituye el contenido de ese archivo por el siguiente:

-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
256M
-vm
C:\Program Files\Java\jre6\bin\javaw.exe
-framework
plugins\org.eclipse.osgi_3.4.3.R34x_v20081215-1030.jar
-vmargs
-Dosgi.requiredJavaVersion=1.5
-Xmx700m
-XX:MaxPermSize=690M

Deje la nueva línea entre la bandera -vm y el valor. A mí me ha funcionado.

1
1
2011-12-30 18:58:41 +0000

En Windows 7 tienes la posibilidad de usar enlaces simbólicos como en unix.

Así que con cmd (ejecutado como administrador), ejecuta lo siguiente: ¡mklink /d jdk jdk-versionnr-etc no necesitas actualizar tu ruta, JAVA_JOME la próxima vez que actualices Java !

1
0
2019-03-17 09:39:08 +0000

Aunque esta es una pregunta antigua, he pensado en añadir algo más de información relevante a la respuesta aceptada dada por @Steffen Opel.

Es posible instalar cualquier número de versiones de JDKs de 32 bits y JDKs de 64 bits en un sistema operativo Windows de 64 bits. También es posible instalar Eclipse de 32 bits y Eclipse de 64 bits en el mismo ordenador. Pero para ejecutar una de esas versiones de Eclipse relacionadas con la plataforma (en el caso de los OPs, Eclipse de 64 bits), la máquina debe tener configuradas las "Variables de entorno" correspondientes al JDK. Esto puede hacerse (debería hacerse) sin modificar el archivo eclipse.ini.

Variables de entorno

Para ejecutar java sin dar la ruta completa es necesario añadir la ubicación del archivo java.exe a la variable de entorno PATH. Y también para algunas otras utilidades de terceros, se requiere la variable de entorno JAVA_HOME.

Normalmente los desarrolladores de java siempre necesitan tener instalado el JDK (JRE está incluido en el JDK). Y PATH se establece en la carpeta "bin" bajo la carpeta de instalación del JDK (en el caso de los OPs C:\Program Files\Java\jdk1.6.0_40\bin) mientras que JAVA_HOME se establece en la carpeta de instalación del JDK (en el caso de los OPs C:\Program Files\Java\jdk1.6_40).

En este caso, el operador sólo tiene un JDK de 32 bits, pero intenta utilizar Eclipse de 64 bits. Así que para arreglar el problema OP necesita instalar JDK de 64 bits. Y cambiar JAVA_HOME & PATH "Variables de entorno" para que coincida con la ubicación de la instalación.

Aquí están los pasos más completos:_

  • Descargar e instalar JDKx.x de 64 bits. 0x2_xx
  • A continuación, abra el Explorador de Windows, haga clic con el botón derecho del ratón en el icono del ordenador y seleccione

  • En la sección Variable de sistema busque el nombre de la variable JAVA_HOME y haga clic en el botón "Editar" de la sección inferior, si no está disponible haga clic en "Nuevo" e introduzca C:\NArchivos de programa\NJava\jdk1.6.0\40 y haga clic en Aceptar.

  • A continuación, seleccione la variable PATH y haga clic en "Edit" y añada %JAVA_HOME%\bin; al principio o %JAVA_HOME%\bin al final de la cadena existente. NO sobreescriba la cadena existente, y haga clic en OK -> OK ->OK para completar.

Ahora Eclipse se abrirá sin el error.

Nota:

  • Si alguien necesita usar Eclipse de 32 bits entonces la ruta del JDK por defecto será C:_ **Archivos de Programa (x86)** __Java\jdkx.x.xxx_

  • Cuando se cambian PATH Variables de entorno en Windows 10 hay una ventana adicional que aparecerá como se muestra en la imagen de abajo.

enter image description here

0
0
2018-12-11 13:18:03 +0000

Para ampliar la respuesta de Steffen Opel, el desajuste se produce entre la JVM especificada en el archivo eclipse.ini y la JVM encontrada y lanzada como resultado de las entradas en la variable de entorno de la ruta de Windows. Así que para solucionar el problema, asegúrese de que ambos se refieren a la misma JVM.

Para solucionar este problema siga estos pasos:

1. Modifique la configuración de Eclipse para que se inicie con la versión deseada de JVM Abra el archivo eclipse.ini y cambie la línea de abajo por la versión de java que desee utilizar, por ejemplo:

-Dosgi.requiredJavaVersion=1.5

2. Asegúrese de que Eclipse puede acceder a la JVM que requiere Vaya al Panel de Control --> Editar Variables de Entorno del Sistema --> Ruta.
   a) Asegúrese de que existe una entrada aquí para su java    b) Asegúrese de que esta entrada se encuentra más arriba (o antes) que cualquier otra ruta de java dentro de su entrada @path.

Esperemos que esto solucione el problema.

0
0
2014-02-25 15:38:55 +0000

Yo estaba enfrentando el mismo problema a pesar de que tenía versiones de 64 bits de ambos JDK y Eclipse. Descubrí que faltaba la ruta del JDK en el archivo eclipse.ini.

Así que añadí las siguientes líneas en el archivo eclipse.ini:

-vm
C:\Program Files\Java\jdk1.7.0_45\jre\bin 

¡Esto resolvió el problema! :-)

0
0
2019-04-11 09:44:53 +0000

Yo había enfrentado el mismo problema, pero tengo la solución.

Comprueba si Eclipse es de 32 o 64 bits, entonces

  1. Si es de 32 bits entonces establece JAVA_HOME a la versión de 32 bits de jdk
  2. Si Eclipse es de 64 bits, entonces establece JAVA_HOME a la versión de 64 bits de jdk
0
0
2015-03-05 07:16:35 +0000

1.Desinstalar jdk7.1 disponible (Era de 64 bits) 2. 2.Descargar e instalar jdk7.1 de 32 bits. El jvm.dll estará en la siguiente ruta "C:\gram Files (x86)\Java\jdk1.7.0_75\jre\bin\client"

Espero que funcione.

0