Usuario del software
2012-06-05 08:24:05 +0000 2012-06-05 08:24:05 +0000

Respuestas [5]

27
2013-10-26 16:00:55 +0000

He resuelto el problema desactivando el firewall para el puerto 80.

  1. Ir a Buscar en la parte derecha de windows.
  2. buscar "firewall".
  3. abrir el "firewall con avanzado".
  4. ir a reglas de entrada.
  5. hacer clic en "nueva regla".
  6. seleccionar la opción "Puerto".
  7. hacer clic en "siguiente"
  8. seleccionar la opción "TCP".
  9. seleccionar "Puertos locales específicos:".
  10. escriba "80" en el siguiente cuadro de texto
  11. haga clic en siguiente.
  12. seleccionar "Permitir la conexión".
  13. haga clic en "siguiente".
  14. hacer clic en "siguiente".
  15. dar el nombre "Port 80 Allow Rule".
  16. haga clic en "siguiente".

Nota: esta no es una forma segura. elimine esta regla recién creada cuando termine su trabajo.

27
4
2012-06-05 13:13:39 +0000

Quizás apache sólo está escuchando en la dirección loopback 127.0.0.1. Compruebe sus archivos de configuración para esto. Para enlazar apache a todas las interfaces disponibles en el puerto 80, configure el cfg a Listen 80

Vea http://httpd.apache.org/docs/2.0/bind.html

Además, puede desactivar temporalmente todo el software de seguridad/firewall mientras lo prueba. O si seguramente sabes cómo, entonces primero comprueba y configura los cortafuegos. Si tu red privada tiene routers puede haber cortafuegos/enrutamiento personalizado que impida a otros conectarse. Vea la respuesta de Bon Gart para más detalles.

4
4
2012-06-05 12:25:21 +0000

Bien. Así que, para ser claros....

Cuando estás sentado en el ordenador que está ejecutando WAMP, y pones la dirección IP EXTERNA en el navegador, puedes ver el servidor web.

Cuando estás sentado en un ordenador diferente en la misma subred IP (conectado al mismo router y/o switch) y pones la dirección IP EXTERNA en el navegador, no ves el servidor web.

Cuando está sentado en otro ordenador que NO está en la misma subred IP (no está conectado al mismo router y/o switch) y pone la dirección IP EXTERNA en el navegador, no ve el servidor web.

¿Has redireccionado el puerto 80 en el router a la dirección IP interna de ese ordenador? ¿Permite tu ISP el acceso/tráfico entrante en el puerto 80? ¿Cómo puedes probar esto? Bueno, primero, asegúrate de que tu router no tiene un firewall que bloquee el tráfico entrante del puerto 80. Asegúrate de que has reenviado correctamente el puerto 80. Asegúrese de que su dirección IP interna es estática (en la tabla DHCP). Si has hecho estas cosas... entonces podría ser un problema con el puerto 80. Puedes probarlo entrando en WAMP y cambiando el puerto utilizado a... lo que sea... 8080. Esto es sólo para propósitos de prueba de todos modos. Luego, vuelve a entrar en el router, y en todos los lugares donde trataste con el puerto 80, cámbialo a 8080. Luego intenta acceder al servidor.

4
3
2012-06-06 18:11:54 +0000

Vaya a:

WAMP → alias → archivo phpmyadmin.conf...

Hay una opción llamada "Deny from all".

Cámbiela por "Permitir desde todos".

Debería funcionar perfectamente.

3
1
2013-07-01 12:00:51 +0000

ir a wamp\alias y hacer modificar los siguientes tres archivos

  1. phpmyadmin.conf
  2. sqlbuddy.conf
  3. webgrind.conf

y reemplazar

Order Deny,Allow
Deny from all
Allow from 127.0.0.1

por

Order Allow,Deny 
Allow from all
1